SchoolFunds Online Degraded Performance

Incident Report for KEV Group

Resolved

The resolution was successfully applied overnight. If you were affected and require any additional assistance, please reach out to our Support Team.

We apologize for the inconvenience this caused.
Posted May 27, 2026 - 13:56 EDT

Identified

We identified the root cause of this issue and will be applying the fix tonight. You should start seeing restored functionality tomorrow. 

We apologize for the impact of this issue on your operations and appreciate your patience. 

We will provide a follow-up update in the morning.
Posted May 26, 2026 - 18:28 EDT

Investigating

We are investigating reports that some SchoolFunds Online users may be experiencing degraded performance, including run-time errors in SFO Accounting and missing accounts when working within SchoolCash Catalog.

SchoolCash Online for purchasers is not affected.

We will provide an update as more information becomes available.
Posted May 26, 2026 - 11:15 EDT
This incident affected: USA (SchoolFunds Online Suite, SchoolFunds Online Accounting Only).